WordPress: Downgrade to old plugin versions (especially related to nextgen-gallery 2.0)

Sometimes ago I wrote a small hack to enhance the WordPress plugin Nextgen-Gallery with captions for the single pictures view. I made it primary formyself but in the meantime there are a lot of other users.

Now the new Nextgen-Gallery owner Photokrati has released the version 2.0 which is internally totally different and therefore terrible incompatible with enhancements like my caption-template. A documentation for creating compatible templates is announced but not released yet. Nextgen-Gallery is a very popular and widespread plugin for WordPress and there are also a lot of third party tools and most of them ecomes incompatible without any warning. That’s realy a tremendous thing.

And there exists also some references that Nextgen 2.0 shows incompatibilities with the new Version 3.6 of WordPress. This is another reason to wait with the update to Nextgen-Gallery 2.0 for a longer time.

However, the update of a plugin in WordPress is so easy but there is no function to revert to an older version. For all that running into the update trap I will in short show how the old version can be reinstalled:

  • Do NOT deinstall Nextgen-gallery using the Dashboard This would delete all your galleries on the server!
  • It’s always a good idea to make an update of the WordPress installation and the database before making such changes.
  • Deactivate the plugin in the Dashboard. (Dashboard->installed plugins)
  • Download the old version (in this case nextgen-gallery 1.9.13) . It’s not easy to find but Nextgen-Gallery is here.
  • Using your favorite FTP-tool, delete the directory “wordpress/wp-content/plugins/nextgen-gallery” from your webspace
  • Unzip the downloaded older version and copy it in the place of the deleted directory.
  • Reload the plugin page in the dashboard and AFTER it reactivate nextgen-gallery. The old version number should be shown at the plugin page (and the update info comes again)
  • … and don’t forget to copy, singlepic-caption.php to the plugin-directory. 😉
  • As soon as a suitable documentation is available I will port my template to the version 2.0.

This entry was posted in Allgemein and tagged . Bookmark the permalink.

3 Responses to WordPress: Downgrade to old plugin versions (especially related to nextgen-gallery 2.0)

  1. Vielen Dank für die Anleitung zum Einspielen der alten Version. Ich hatte schon befürchtet, durch alles Artikel gehen zu müssen…

    Liebe Grüße – Angelika

  2. Michael says:

    Herzlichen Dank,
    die Anleitung hat mir das Leben gerettet.
    Leider ist man immer schell dabei auf Aktualisieren zu klicken ohne nocheinmal nachzuprüfen ob es passt.
    Den letzen Punkt habe ich allerdings nicht verstanden (nicht vergessen). Hat aber trotzdem funktioniert.

    Danke Michael

    • Ralf says:

      Hallo Michael,

      danke für die nette Rückmeldung!!!

      Der letzte Punkt war ein kleiner Scherz, um meine Nextgen-Gallery Erweiterung zu promoten. Wer die nicht braucht, muss sie natürlich nicht mit rüber kopieren. (Schadet aber auch nicht)

      Ralf

Leave a Reply

Your email address will not be published.

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.